Back to overview
Downtime
Internal System issues
Jan 20, 2024 at 1:07am UTC
Affected services
EcoZend API Status
Resolved
Jan 21, 2024 at 10:38pm UTC
We've loaded a Backup and everything looks normal.
Affected services
Created
Jan 20, 2024 at 1:07am UTC
Due to an NDA, we cannot provide any more detailed information on this case.
Affected services