Back to overview
Geo Block Misconfiguration
Jan 30 at 11:28am CET
Affected services
EcoZend API Status
Resolved
Jan 30 at 11:28am CET
We fixed it and everything should work now again
Affected services
Resolved
Jan 30 at 11:28am CET
We fixed it and everything should work now again
Affected services