Back to overview
Downtime

Issues receiving E-Mails

Apr 05 at 10:21pm CEST
Affected services
Mail Server

Resolved
Apr 05 at 10:46pm CEST

We've fixed this issue but we are not sure if there is a data loss. We continue investigate that

Updated
Apr 05 at 10:35pm CEST

We've identified the issue. We are currently working on fixing this issue

Created
Apr 05 at 10:21pm CEST

Hello, we are currently experiencing major issues with our Mail Services. We are currently working on it.