Back to overview
Downtime
SSL Handshake Error
Apr 10 at 09:44pm CEST
Affected services
EcoZend API Status
Resolved
Apr 10 at 10:36pm CEST
The problems have been fixed. We apologise for the downtime!
Affected services
Updated
Apr 10 at 10:23pm CEST
We've implemented a fix. We're investigating the results.
Affected services
Created
Apr 10 at 09:44pm CEST
We're currently aware of an SSL Handshake error.
Affected services