Back to overview
Downtime

Internal Server Issues

Apr 22 at 03:05pm CEST
Affected services
EcoZend API Status

Resolved
Apr 22 at 03:18pm CEST

We have found the problem and already fixed it.

Created
Apr 22 at 03:05pm CEST

We are currently experiencing internal server issues. We are currently working on a fix.